Wednesday, February 27, 2013

RHEL 6.4 and ELRepo

RHEL 6.4 was released on February 21th, 2013. We have tested our packages against this release and identified a couple of issues. Below is a digest of our note sent to the ELRepo mailing list.  

1. The current OpenAFS kmod package in elrepo (kmod-openafs-1.6.1-2.el6.elrepo) does not weak-link against the new 6.4 kernel. Jack Neely rebuilt the kmod against the new 6.4 kernel (kmod-openafs-1.6.1-5.el6.elrepo) but that package does not in turn weak-link against earlier kernels. So users of 6.3 should continue to use the package in the main repository (kmod-openafs-1.6.1-2.el6.elrepo). When you are ready to update to 6.4, also update kmod-openafs (kmod-openafs-1.6.1-5.el6.elrepo) from the elrepo testing repository at the same time.   

2. Red Hat updated the wireless stack in RHEL 6.4. As a result, there now exists a file level conflict between the kernel-firmware package and the rt2860-firmware and rt2870-firmware packages from elrepo, both providing the same file(s). Users of these devices are advised to uninstall the elrepo drivers and firmware for these devices and revert to the kernel drivers now these devices are supported by the distro.

Tuesday, February 19, 2013


Having received a system-generated message that the mainline linux-3.8 tarball was available at the Linux Kernel Archives, it was downloaded and fed into the ELRepo Project's build system.

After the dispatch of one e-mail in-box full of messages and an evening meal, the build status was checked. The expected message was duly seen --
All packages have been built.
 So just three steps remained -- package signing, uploading to the elrepo-kernel repository and announcing the release of this package set to our mailing-list.

By now our mirror-sites will be synchronising with this latest kernel-ml release and so it is all over -- until the next tarball is released.